sqlserver2005服务无法启动(win7系统安装SQLServer2005提示“SQL Server服务无法启动”怎么办)

本文目录
- win7系统安装SQLServer2005提示“SQL Server服务无法启动”怎么办
- sqlserver2005无法启动
- sql server 2005 服务无法启动
- 急,SQLServer2005的SQL Server (SQLEXPRESS)服务无法启动
- win7系统SQLServer2005提示SQL Server服务无法启动解决方法
- sql server 服务无法启动
win7系统安装SQLServer2005提示“SQL Server服务无法启动”怎么办
SQL server服务无法启动的原因分析:
在安装SQL 2005标准版(不多于四个CPU)和企业版(无限制)时,CPU的总核数必须是2的n次方。即核心数为1,2,4,8,16,32依次类推。因BL680C核心数为6x4=24,所以不能正常安装。当将核心数更改为8,16时,顺利完成安装。 说实话,觉得这么做很不可思议,居然与核心数有关。继续吧,按照上面所说的步骤,修改了“/NUMPROC”,此处我先说一下,我把“/NUMPROC”改为1,4,8都不能正常安装SQL Server 2005,唯独改为2后,可以正常安装。
2
上面长篇累牍,看起来有些乱,下面整理了正确的安装步骤,大家参考吧。
1.单击开始,单击运行,键入msconfig,然后单击确定。在系统配置实用程序对话框中,单击BOOT.INI选项卡。在BOOT.INI选项卡上单击高级选项。在BOOT.INI高级选项对话框中,单击以选中在/NUMPROC=复选框。在旁边的列表在/NUMPROC=复选框,单击2,然后单击确定。在系统配置实用程序对话框中,单击确定。重新启动服务器。
2.安装SQL Server 2005。
3.安装SQL Server 2005 sp3补丁,安装结束后,重新启动服务器。
4.将上面说的“/NUMPROC”去掉钩,重新启动服务器
5.大功告成!
sqlserver2005无法启动
安装了防火墙,杀毒软件没,如果有的话,把防火墙,杀毒软件先关了,以防止这些屏蔽了SQL端口;不知道你之前有没有装过SQL,如果装过后来又卸载再重新装的话也会出现问题的,卸载不干净会导致安装不成功;象你这种情况最好检查一下MSSQLSERVER服务的端口是否被关闭了,如果是的话手动添加端口然后在看看。你可以试一试:(1)开始-》程序-》Microsoft SQL Server 2005-》SQL Server 2005外围应用配置器,在打开的界面单击"服务的连接的外围应用配置器",在打开的界面中找到Database Engine,单击"服务",在右侧查看是否已启动,如果没有启动可单击"启动",并确保"启动类型"为自动,不要为手动,否则下次开机时又要手动启动;
(2)可打开:开始-》程序-》Microsoft SQL Server 2005-》配置工具-》SQL Server Configuration Manager,选中SQL Server 2005服务中SQL Server(MSSQLSERVER) ,并单击工具栏中的"启动服务"按钮把服务状态改为启动;
sql server 2005 服务无法启动
欢迎光临百度知道 即时在线QQ求助:87685073
你的数据库打开了 但是有问题 所以连接中报错 你可以通过系统日志 查看具体出现错误的原因 如果还是找不到 那就是数据库文件损坏了 我遇到过用瑞星,导致进不去数据库的例子 当时我就是用另一个方法解决的 让别人给你传一个你需要的数据库 覆盖下就可以了 记得备份 搞不定可以加我 随时帮忙
急,SQLServer2005的SQL Server (SQLEXPRESS)服务无法启动
原因基本就这4种:
1,你的sqlbrowser这个服务没有开启,这点你可以去你的服务管理里面看看
2,你的tcp协议不被允许,这个原因我不知道怎么改
3,不支持远程连接,你可以试着把PC201203272233改为你本机当前的ip试试
4,你的database SQLEXPRESS这个为特殊数据库不让访问或者不存在。你可以尝试别的数据库
win7系统SQLServer2005提示SQL Server服务无法启动解决方法
SQLServer2005是一个全面的数据库平台,使用集成的商业智能 (BI)工具提供了企业级的数据管理。有位win7系统用户安装SQLServer2005出现错误提示SQL Server 2005 安装错误码29503。产品: Microsoft SQL Server 2005-- 错误 29503。SQL Server 服务无法启动。有关详细信息,请参阅 SQL Server 联机丛书中的主题如何查看 SQL Server 2005 安装日志文件和手动启动 SQL Server。(如下图所示),怎么办?接下来小编分享故障原因和解决方法。
错误原因:
多核cpu安装sql server2005 时不能安装(因为无法启动sql server服务,从而导致无法安装)。我所安装的服务器是HP服务器32核CPU,SQL Server2005 无法识别多核,从而导致安装失败。SQL Server 2008不存在此问题。
解决方案
1、在命令行输入msconfig,选择BOOT.INI高级选项,勾选/NUMPROC数值选择为最大的2的n次方(2/4/8),不能超过机器的总核数。点击确定,然后重启电脑,重启电脑设置才能生效;
2、安装SQL Server 2005,这次不会再出现服务无法启动的错误,应该会很顺利;
3、安装Service Package 3,SQL Server SP3补丁;
4、然后再次输入msconfig,打开【常规】选项卡,在常规选项卡上单击正常启动-加载所有设备驱动程序和服务,然后单击确定;
5、重启电脑,一切搞定。
关于win7系统安装SQLServer2005提示SQL Server服务无法启动的解决方法分享到这里了,遇到一样情况的用户可参考本文教程解决。
sql server 服务无法启动
安装了防火墙,杀毒软件没,如果有的话,把防火墙,杀毒软件先关了,以防止这些屏蔽了SQL端口;不知道你之前有没有装过SQL,如果装过后来又卸载再重新装的话也会出现问题的,卸载不干净会导致安装不成功;象你这种情况最好检查一下MSSQLSERVER服务的端口是否被关闭了,如果是的话手动添加端口然后在看看。

更多文章:
word表格上下分离了怎么办(word里面怎样把上下页面的两个表格接在一起)
2026年10月11日 07:40







